Back to overview
Resolved
Login Service Disruption
Jul 16, 2026 at 7:51am UTC
Affected services
id.pay.com.au
Resolved
Jul 16, 2026 at 10:41am UTC
Our identity provider has remediated the issue, and login services have been fully restored. Customers can now log in to the Pay.com.au website and mobile app as normal. We will continue to monitor the service to ensure ongoing stability.
Affected services
Created
Jul 16, 2026 at 7:51am UTC
We have identified an outage with our identity provider that is preventing customers from logging in to the Pay.com.au website and mobile app. We are working with the provider to restore service and will provide further updates as they become available.
Affected services